Increased bounce or delay rate for Apple domains

Incident Report for SparkPost

Resolved

Delivery rates to Apple domains have returned to normal with no further elevated delays or bounces. We will perform any necessary post-incident cleanup of suppression lists to ensure no recipients were incorrectly suppressed during the outage.
Posted Apr 05, 2026 - 15:01 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 05, 2026 - 14:27 EDT

Identified

The issue was caused by an Apple iCloud Mail outage (https://www.apple.com/support/systemstatus/), which Apple has since marked as resolved. Bounce rates and delivery delays to Apple domains have returned to normal levels. We are currently reviewing our suppression lists to identify and remove any recipients that may have been incorrectly added during the incident.
Posted Apr 05, 2026 - 13:58 EDT

Investigating

We are currently investigating reports of delayed or failed email deliveries to Apple-hosted domains. Messages to non-Apple domains are unaffected. We will provide updates as more information becomes available.
Posted Apr 05, 2026 - 13:02 EDT
This incident affected: SMTP Delivery (Outbound Message Delivery) (SMTP Delivery - USA, SMTP Delivery - EUROPE).