Increased Bounce rate for Apple iCloud.com domain
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 13:46 EDT
Monitoring
We are currently delivering to mac.com MX records in all regions. Invalid suppression entries for mac.com, me.com, and icloud.com have been purged from customer suppression lists.
Posted Apr 26, 2021 - 13:08 EDT
Update
We are continuing to monitor the situation. We are still delaying all mail to mac.com MX records. We will be purging any invalid suppression entries from our system once the incident is complete.
Posted Apr 26, 2021 - 12:32 EDT
Identified
Apple's status page update. https://www.apple.com/support/systemstatus/
Posted Apr 26, 2021 - 09:20 EDT
Update
We have delayed all mail to the mac.com MX records.
Posted Apr 26, 2021 - 09:07 EDT
Investigating
We are currently seeing high percentage of '550 5.1.1 : user lookup success but no user record found' for valid addresses on the iCloud.com domain. We are currently investigating the issue.
Posted Apr 26, 2021 - 09:05 EDT
This incident affected: SMTP Delivery (Outbound Message Delivery) (SMTP Delivery - USA, SMTP Delivery - EUROPE).