Webhook delays for some SparkPost customers (US hosted only)

Incident Report for SparkPost

Resolved

This issue has been resolved. We apologize for any inconvenience it may have cause.
Posted Nov 20, 2025 - 13:23 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2025 - 12:16 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 20, 2025 - 11:12 EST

Investigating

Our webhook data delivery services are running behind and some customers may see a delay in data streamed to their webhook endpoints.

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Nov 20, 2025 - 10:56 EST
This incident affected: Event Webhook Delivery Service (Event Webhooks - USA).