Elevated 5xx API error rates and increased latency for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 06:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2021 - 06:44 EDT
Update
We are currently working with our service provider on this issue. We continue to see periodic errors from the Suppression List API
Posted Jul 19, 2021 - 06:19 EDT
Investigating
We are experiencing an elevated level of API and UI errors and latency for our APIs for some SparkPost and SparkPost Enterprise customers (including Transmissions API and SMTP injection API). Please retry any 5xx error.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Jul 19, 2021 - 04:46 EDT
This incident affected: Tracking Domains API (Tracking Domains API - USA), Suppression List API (Suppression List API - USA), Sending Domains API (Sending Domains API - USA), Templates API (Templates API - USA), IP Pools API (IP Pools API - USA), Sending IPs API (Sending IPs API - USA), Relay Webhooks Delivery Service (Relay Webhooks - USA), SparkPost Application (WebUI) (SparkPost Application - USA), Transmissions API (Transmissions API - USA), Metrics API (Metrics API - USA), Events API (Events API - USA), and SMTP API (SMTP API - USA).