Elevated reporting error rates and data processing delays for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 14:46 EST
Monitoring
All reporting data is caught up with the exception of webhooks. This should be cleared in a few minutes.
Posted Dec 02, 2019 - 14:34 EST
Update
The data processing backload is clearing out and should be fully resolved soon
Posted Dec 02, 2019 - 13:30 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 02, 2019 - 11:37 EST
Investigating
Our data processing services are running behind for some customers and we're seeing intermittent slowness and elevated error rates on our reporting APIs. Specifically, some customers may see latency issues, 500 errors or a delay of data on:

Web UI
Metrics API
Message Events API
Webhooks

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Dec 02, 2019 - 10:36 EST
This incident affected: Relay Webhooks Delivery Service (Relay Webhooks - USA), SparkPost Application (WebUI) (SparkPost Application - USA), Metrics API (Metrics API - USA), and Message Events API (Message Events API - USA).