Data Process is delayed for Sparkpost US - EU

Incident Report for SparkPost

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 00:33 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 07, 2025 - 23:51 EST

Update

We have been able to catch up all data from the 5th and are working on the 6th now.
Posted Dec 07, 2025 - 23:26 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 07, 2025 - 22:21 EST

Investigating

Our data processing services are running behind; some customers may see a delay of data available via the:

- SparkPost App (webUI): Signals Reports
- Events API
- Metrics API

Message injection and outbound message delivery are not impacted - all messages are flowing as expected.
Posted Dec 07, 2025 - 21:24 EST
This incident affected: Metrics API (Metrics API - USA, Metrics API - EUROPE), Events API (Events API - USA, Events API - EUROPE), and SparkPost Application (WebUI) (SparkPost Application - USA, SparkPost Application - EUROPE).