We have seen fully recovery from this delay event. A postmortem will be posted shortly detailing the root cause and steps we have taken to prevent a reoccurrence.
Posted Nov 27, 2025 - 10:24 EST
Update
We continue to see significant recovery on the delayed messages. Continuing to monitor and will post the next status after full recovery.
Posted Nov 27, 2025 - 09:50 EST
Update
The MTA1 cluster is beginning to stabilize and we are seeing active recovery. We will continue to monitor and provide updates as the cluster fully recovers.
Posted Nov 27, 2025 - 09:44 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 27, 2025 - 09:23 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 27, 2025 - 09:22 EST
Investigating
We are investigating an increase in delivery latency for some outbound messages. (NOTE: This does not impact our customers hosted in the EU.)