We are seeing signs of recovery. Yahoo's mail servers are beginning to accept messages normally and delivery rates are improving. Current Status:
Yahoo appears to be resolving their infrastructure issues Delivery success rates are increasing Queued messages are being processed and delivered We continue to monitor closely to ensure full recovery
What to Expect: Messages that were queued during the incident are being delivered as Yahoo's systems recover You may see a temporary spike in delivery volume as the backlog clears Delivery times should return to normal as the queue processes
We will continue to monitor the situation closely and will post a final update once we confirm full recovery.
Posted Nov 28, 2025 - 04:54 EST
Identified
We have confirmed this is an issue with Yahoo's receiving infrastructure. Yahoo's mail servers continue to return temporary failure codes that are preventing normal mail delivery.
Current Status: The issue has been confirmed to be on Yahoo's side Our sending infrastructure is operating normally All queued messages will be delivered automatically once Yahoo resolves their infrastructure issues No customer action is required
Error Messages You May See: If you're monitoring your delivery logs, you may see the following (non-inclusive) temporary failure messages from Yahoo: 451 4.4.2 [internal] no BODY response 451 4.4.2 [internal] connection closed by remote host 451 4.4.2 [internal] no MAIL FROM response 451 4.4.2 [internal] no RCPT TO response 421 Service not available, closing transmission channel tnmpmscs
These are all temporary errors from Yahoo's infrastructure. Messages receiving these errors are being automatically retried and will be delivered once Yahoo resolves the issue.
We are continuing to monitor the situation and will provide updates as Yahoo works to resolve this on their end.
Posted Nov 28, 2025 - 04:53 EST
Investigating
We are currently experiencing delays in email delivery to Yahoo recipients. Our monitoring systems have detected increased queue times for messages destined for Yahoo domains (yahoo.com, ymail.com, etc.). Current Status:
Email delivery to Yahoo is experiencing delays This appears to be a receiving issue on Yahoo's infrastructure Our sending systems are operating normally All other ISPs and providers are unaffected
Impact: Messages to Yahoo recipients are being queued and will be delayed No messages are being lost or dropped Our systems will continue automatically retrying delivery per our normal retry schedule
Posted Nov 28, 2025 - 04:40 EST
This incident affected: Events API (Events API - USA), SparkPost Application (WebUI) (SparkPost Application - USA), and Event Webhook Delivery Service (Event Webhooks - USA).