Webhooks: Duplicate message events for some customers (US REGION)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Jan 16, 2024 - 16:36 EST
Monitoring
Earlier today at 15:00 UTC we rolled out an update to the event webhooks framework in the US region and this caused some customers to receive events more than once (the incident ended at 20:30 UTC). While we don't guarantee zero duplication of data received via webhooks, this incident caused some customers to receive up to twice the number of events expected during this timeframe. We are letting you know because it resulted in a significant bump in webhooks traffic for some customers.
(No extra action is necessary for those customers who already de-duplicate data using event_id.)
Posted Jan 16, 2024 - 15:47 EST
This incident affected: Event Webhook Delivery Service (Event Webhooks - USA).