SparkPost errors and data processing delays for SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved and all services are running normally.
Posted Aug 31, 2021 - 20:35 EDT
Monitoring
A fix has been implemented and we are monitoring results. Webhook data is still catching up and we expect that to be done in about 1 hour. All other services are running normally.
Posted Aug 31, 2021 - 19:14 EDT
Identified
The issue has been identified and we continue to work with our cloud service provider. Summary of impact:
- REST APIs have a slightly elevated error rate (continue to retry 5xx errors)
- Webhook data streams are running 1+ hour behind
- Events and Metrics are running 1/2 hour behind
NOTE: Outbound message delivery is NOT impacted
Posted Aug 31, 2021 - 16:00 EDT
Update
This incident appears to be impacting many of our core services including injection APIs and data processing services like webhooks. We are investigating and we have engaged our cloud service provider.

This incident does not impact our customer provisioned in the EU.
Posted Aug 31, 2021 - 14:53 EDT
Update
We are continuing to investigate this issue.
Posted Aug 31, 2021 - 14:27 EDT
Investigating
Our webhook data delivery services are running behind and some customers may see a delay in data streamed to their webhook endpoints.
Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Aug 31, 2021 - 14:27 EDT
This incident affected: Metrics API (Metrics API - USA), Transmissions API (Transmissions API - USA), Events API (Events API - USA), SparkPost Application (WebUI) (SparkPost Application - USA), SMTP API (SMTP API - USA), Sending Domains API (Sending Domains API - USA), Relay Webhooks Delivery Service (Relay Webhooks - USA), Event Webhook Delivery Service (Event Webhooks - USA), and Suppression List API (Suppression List API - USA).