Elevated delays to Microsoft domains
Incident Report for SparkPost
Resolved
The issue at Microsoft appears to be resolved - the rate of delayed messages is back in the normal range.
Posted Jun 05, 2023 - 19:10 EDT
Monitoring
We are continuing to monitor.
Posted Jun 05, 2023 - 17:40 EDT
Identified
We are seeing an elevated rate of delays while delivering email to Microsoft domains (~5-10%). We believe the issue is industry-wide as other providers are reporting the same issue. Delayed messages will be retried - no action is necessary at this time.
Posted Jun 05, 2023 - 17:07 EDT
This incident affected: Mailbox Provider Service Interruption.