Health Score and Cohort data is delayed

Incident Report for SparkPost

Resolved

The data has all been posted. We apologize for the delay.
Posted Sep 14, 2026 - 12:46 EDT

Monitoring

Data is reprocessed and loads are completing. Full data recovery expected in the next 30 minutes.
Posted Sep 14, 2026 - 12:31 EDT

Identified

We know what has caused the data delay and are working to get the data posted.
Posted Sep 14, 2026 - 10:59 EDT

Investigating

Health score and Cohort data is delayed.
Posted Sep 14, 2026 - 10:19 EDT
This incident affected: SparkPost Application (WebUI) (SparkPost Application - USA, SparkPost Application - EUROPE).