Data processing delays

Incident Report for SparkPost

Resolved

This incident has been resolved.
Posted Dec 10, 2025 - 19:32 EST

Monitoring

Our pipeline that was having issue has recovered. We are monitoring to ensure we stay in a good state. Very sorry for the inconvenience.
Posted Dec 10, 2025 - 19:23 EST

Investigating

We are currently looking into a data delay. This is causing our metrics to be delayed. It is not effecting mail sending.
Posted Dec 10, 2025 - 16:22 EST
This incident affected: Metrics API (Metrics API - USA, Metrics API - EUROPE), Events API (Events API - USA, Events API - EUROPE), SparkPost Application (WebUI) (SparkPost Application - USA, SparkPost Application - EUROPE), and Event Webhook Delivery Service (Event Webhooks - USA, Event Webhooks - EUROPE).