Elevated reporting error rates and data processing delays for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Oct 31, 2019 - 13:47 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 31, 2019 - 12:58 EDT
Investigating
Our data processing services are running behind and we're seeing intermittent slowness and elevated error rates on our reporting APIs. Specifically, some customers may see latency issues, 500 errors or a delay of data on:

Web UI
Metrics API
Message Events API
Webhooks

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Oct 31, 2019 - 12:06 EDT
This incident affected: SparkPost Application (WebUI) (SparkPost Application - USA), Metrics API (Metrics API - USA), Message Events API (Message Events API - USA), and Event Webhook Delivery Service (Event Webhooks - USA).