Elevated data processing delays for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Aug 12, 2021 - 16:33 EDT
Update
A fix has been implemented and we are monitoring the results. Data processing services for webhooks are operational - event data is flowing via webhooks. We are working through the backlog of event data and data will be caught up in the next hour (CORRECTION by 21:00 UTC).
Posted Aug 12, 2021 - 16:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results. Data processing services for webhooks are operational - event data is flowing via webhooks. We are working through the backlog of event data and data will be caught up in the next hour (by 19:00 UTC).
Posted Aug 12, 2021 - 15:59 EDT
Update
UPDATE: Data processing services for webhooks are running behind; event data is not currently being delivered and is expected to resume shortly.

APIs - no impact to any APIs
Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Aug 12, 2021 - 15:41 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 12, 2021 - 15:21 EDT
Investigating
Our data processing services are running behind and we're seeing intermittent slowness and elevated error rates on our reporting APIs. Specifically, some customers may see latency issues, 500 errors or a delay of data on:

Webhooks

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Aug 12, 2021 - 15:18 EDT
This incident affected: Event Webhook Delivery Service (Event Webhooks - USA).