Elevated data processing delays for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 28, 2019 - 11:05 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jan 28, 2019 - 10:32 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Jan 28, 2019 - 10:25 EST
Investigating
Our data processing services are running behind and we're seeing intermittent slowness and elevated error rates on our reporting APIs. Specifically, some customers may see latency issues or a delay of data on:

Web UI
Metrics API
Message Events API
Event Search API
Webhooks

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted 3 months ago. Jan 28, 2019 - 10:11 EST
This incident affected: Message Events API (Message Events API - USA), Metrics API (Metrics API - USA), SparkPost Application (WebUI) (SparkPost Application - USA), and Relay Webhooks Delivery Service (Relay Webhooks - USA).