We have implemented additional tuning to handle the significant influx of mail due to the AWS network outage and we are seeing improvement in delivery rates
We are seeing significant recovery and expect most mail to be fully delivered in the next 30-35 minutes. Estimated time for full recovery is 80-90 minutes.
We are continuing to look for additional optimizations and monitor the issue.
Posted Jul 24, 2026 - 13:29 EDT
Update
We are still working through the queued messages.
We are continuing to monitor the issue and continuing to accept emails.
Posted Jul 24, 2026 - 09:16 EDT
Monitoring
We are starting to deliver mails in our US West region. We are working through the queued messages.
We are continuing to monitor the issue and continuing to accept emails.
Posted Jul 24, 2026 - 08:08 EDT
Identified
Outbound email delivery is blocked for our US West region. We working with our vendor resolve the issue.
We are continuing to accept emails and queue them internally. We will deliver the messages as soon as the issue is resolved.
Posted Jul 24, 2026 - 07:53 EDT
Investigating
We are investigating delivery issues caused by an ongoing AWS US West 2 region outage.
Customers may experience delays while we assess the impact to our service. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted Jul 24, 2026 - 07:14 EDT
This incident affected: Transmissions API (Transmissions API - USA), SMTP API (SMTP API - USA), and SMTP Delivery (Outbound Message Delivery) (SMTP Delivery - USA).