Elevated opens and clicks for messages delivered to Office 365 addresses
Incident Report for SparkPost
Resolved
This incident has been resolved - customers are no longer observing an elevated number of opens and clicks from Office 365 addresses.
Posted Feb 12, 2024 - 11:15 EST
Monitoring
Some customers continue to report elevated opens and clicks from Office 365 addresses. We continue to engage with Microsoft and we have escalated this issue. We will provide updates via this Incident when we receive updates from Microsoft; the next update will be no later than 1 pm EST Monday.
Posted Feb 09, 2024 - 16:29 EST
This incident affected: Mailbox Provider Service Interruption.