Email delivery in US region affected

Incident Report for SparkPost

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 07:25 EDT

Monitoring

System functionality has been fully restored and all emails are being transmitted correctly without added latencies; we are actively monitoring.
Posted Mar 12, 2026 - 06:03 EDT

Investigating

Email delivery in US is impacted, experiencing elevated delays.
Posted Mar 12, 2026 - 04:00 EDT

Monitoring

System is fully recovered and under monitoring.
Posted Mar 12, 2026 - 03:48 EDT

Investigating

We are currently investigating issues with delivery of email impacting US region.
Posted Mar 12, 2026 - 02:51 EDT
This incident affected: SMTP Delivery (Outbound Message Delivery) (SMTP Delivery - USA).