Elevated 4xx API error rates and increased latency for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
We investigated several of the reports and identified these are not due to a system issue. For example, in one case the customer deleted the user that owned their API keys causing API calls to be unauthorized.
Please submit a detailed support ticket if you have any issues.
Posted Dec 14, 2017 - 08:57 EST
Update
We are continuing to investigate reports from a few customers, though we are not seeing a widespread issue.
Posted Dec 14, 2017 - 08:07 EST
Investigating
We are experiencing an elevated level of API "unauthorized" errors for our APIs for some SparkPost and SparkPost Enterprise customers (including Transmissions API and SMTP injection API).
Note: This issue does not impact our SparkPost Enterprise customers hosted in the EU.
Posted Dec 14, 2017 - 07:37 EST
This incident affected: Metrics API (Metrics API - USA), Transmissions API (Transmissions API - USA), Events API (Events API - USA), SMTP API (SMTP API - USA), Sending Domains API (Sending Domains API - USA), SMTP Delivery (Outbound Message Delivery) (SMTP Delivery - USA), and Relay Webhooks Delivery Service (Relay Webhooks - USA).