Elevated reporting error rates and data processing delays for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Jul 07, 2021 - 15:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 07, 2021 - 15:15 EDT
Investigating
Our data processing services are running behind and we're seeing intermittent slowness and elevated error rates on our reporting APIs. Specifically, some customers may see latency issues, 500 errors or a delay of data on:

Events API

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Jul 07, 2021 - 14:34 EDT
This incident affected: Events API (Events API - USA).