Elevated 5xx Transmissions API error rates and latency for some SparkPost customers (US hosted only)

Incident Report for SparkPost

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 14:41 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2026 - 14:38 EST

Identified

The team has identified the root cause. There is a core networking issue that has impacted sending across the clusters.
Posted Feb 24, 2026 - 14:34 EST

Update

We are continuing to investigate this issue. We still see 5xx errors on mail injections and degradation.
Posted Feb 24, 2026 - 14:25 EST

Update

We are continuing to investigate this issue.
Posted Feb 24, 2026 - 14:07 EST

Investigating

We are experiencing an elevated level of errors and latency on the Transmissions API (injection API) for some SparkPost customers. Please retry any 5xx error.

Note: This issue does not impact SparkPost customers hosted in the EU.
Posted Feb 24, 2026 - 14:07 EST
This incident affected: Transmissions API (Transmissions API - USA).