Elevated reporting error rates and data processing delays for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Dec 03, 2019 - 22:24 EST
Identified
Our data processing services are running behind and we're seeing intermittent slowness and elevated error rates on our reporting APIs. Specifically, some customers may see latency issues, 500 errors or a delay of data on:

Web UI
Metrics API
Message Events API
Webhooks

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.

We identified the issue and are applying a fix
Posted Dec 03, 2019 - 22:01 EST
This incident affected: Relay Webhooks Delivery Service (Relay Webhooks - USA, Relay Webhooks - EUROPE), SparkPost Application (WebUI) (SparkPost Application - USA, SparkPost Application - EUROPE), Metrics API (Metrics API - USA, Metrics API - EUROPE), and Message Events API (Message Events API - USA, Message Events API - EUROPE).