Data processing delays for SparkPost customers - US region
Incident Report for SparkPost
Resolved
Service has been restored
Posted Mar 31, 2024 - 10:49 EDT
Update
We have had over an hour without any spikes in errors. We are continuing to monitor.
Posted Mar 30, 2024 - 23:41 EDT
Update
We are seeing almost complete recovery. We have a couple short of bursts of errors per hour. We will continue to monitor till we have full recovery.

Message injection and outbound message delivery are not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU region.
Posted Mar 30, 2024 - 18:48 EDT
Update
We are continuing to see improvements in the 5xx error rates. However, we are still seeing short bursts of raised error rates. We will continue to monitor until full recovery.

Message injection and outbound message delivery are not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU region.
Posted Mar 30, 2024 - 13:35 EDT
Monitoring
We are continuing to see improvements in the 5xx error rates. However, we will continue to monitor the error rates and performance until full recovery.

Message injection and outbound message delivery are not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU region.
Posted Mar 29, 2024 - 11:45 EDT
Update
We are continuing to investigate the issue. Our data processing services are running behind; some customers may see increased 5xx errors or a delay of data available via the:

- SparkPost App (webUI): Signals Reports
- Metrics API

Message injection and outbound message delivery are not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU region.
Posted Mar 28, 2024 - 15:08 EDT
Investigating
Our data processing services are running behind; some customers may see a delay of data available via the:

- SparkPost App (webUI): Signals Reports
- Metrics API

Message injection and outbound message delivery are not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU region.
Posted Mar 28, 2024 - 14:43 EDT
This incident affected: Metrics API (Metrics API - USA) and SparkPost Application (WebUI) (SparkPost Application - USA).