Elevated percentage of API calls failing

Incident Report for SparkPost

Resolved

After a period of extended monitoring, we have confirmed the remediation has completely resolved the issue. Requests and error rates have been normal since 06:27UTC
Posted May 13, 2025 - 07:29 EDT

Identified

We have identified the cause as a set of stale IPs for an upstream service. We are now validating the approach for remediation.
Posted May 13, 2025 - 02:26 EDT

Update

We are still investigating. During the period, the error rate has remained low as initially reported, approximately ~0.015%.
Posted May 13, 2025 - 01:52 EDT

Investigating

We are investigating an unexpected but small increase in the percentage of API calls failing since 01:30UTC. Approximately 0.015% of API calls are failing with a HTTP 504 (Gateway timeout) error. We will update this incident as we have more information.
Posted May 13, 2025 - 01:22 EDT
This incident affected: Metrics API (Metrics API - USA, Metrics API - EUROPE), Transmissions API (Transmissions API - USA, Transmissions API - EUROPE), Events API (Events API - USA, Events API - EUROPE), SMTP API (SMTP API - USA, SMTP API - EUROPE), Sending Domains API (Sending Domains API - USA, Sending Domains API - EUROPE), Suppression List API (Suppression List API - USA, Suppression List API - EUROPE), Blocklist API (Blocklist API - USA, Blocklist API - EUROPE), and Alerts API (Alerts API - USA, Alerts API - EUROPE).