Webhook delays for some SparkPost customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 14:30 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2023 - 13:04 EDT
Identified
The issue has been identified and we working on a fix.
Posted Mar 14, 2023 - 12:32 EDT
Investigating
Our webhook data delivery services are running behind and some customers may see a delay in data streamed to their webhook endpoints.

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Mar 14, 2023 - 12:14 EDT
This incident affected: Event Webhook Delivery Service (Event Webhooks - USA).