Elevated data processing delays and low levels of transmissions errors for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
The upstream issue is resolved and the backlog of data has been processed. All systems are operational.
Posted Jun 26, 2020 - 18:03 EDT
Monitoring
Our upstream provider has identified their issue and have resolved it. The Transmissions API is operational with no errors. Data processing for Webhooks and Wetrics APIs may be delayed while we clear the backlog of data.
Posted Jun 26, 2020 - 17:51 EDT
Update
We are continuing to monitor the situation with our upstream provider and are in close communication with them. We're sorry for any inconvenience.
Posted Jun 26, 2020 - 17:43 EDT
Identified
We have identified that our upstream provider is having an issue. We are in communication with them and are awaiting resolution.
Posted Jun 26, 2020 - 16:11 EDT
Update
We are continuing to investigate this issue. This seems to be an underlying issue with an upstream service provider. We are starting to see impact in Transmissions API as well, with low levels of 5XX errors on that API.
Posted Jun 26, 2020 - 15:58 EDT
Update
We are continuing to investigate this issue.
Posted Jun 26, 2020 - 15:51 EDT
Investigating
Our data processing services are running behind. Specifically, some customers may see a delay of data on:

Metrics
Webhooks

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Jun 26, 2020 - 15:16 EDT
This incident affected: Metrics API (Metrics API - USA), Transmissions API (Transmissions API - USA), and Event Webhook Delivery Service (Event Webhooks - USA).