Delayed email delivery in EU west 1
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Nov 29, 2024 - 11:22 EST
Update
Mail queues are drained, except for a single IP Pool for one customer. New messages are being accepted and delivered without delays.

We are working with the affected customer

We are also continuously monitoring the situation.
Posted Nov 29, 2024 - 07:24 EST
Update
A solution has been implemented and the queue is decreasing. We are continuously monitoring the situation.

New messages are being accepted and delivered without delays.

We expect the backlog of messages to be processed by 11:20 UTC

No messages are lost.
Posted Nov 29, 2024 - 06:06 EST
Update
A solution has been implemented and the queue is decreasing. We are continuously monitoring the situation.

New messages are being accepted and delivered without delays.

We expect the backlog of messages to be processed by 11:20 UTC

No messages are lost.
Posted Nov 29, 2024 - 06:05 EST
Monitoring
A solution has been implemented and the queue is decreasing. We are continuously monitoring the situation. New messages are being accepted and sent. No messages are lost.
Posted Nov 29, 2024 - 05:07 EST
Update
We are continuously monitoring the situation. We are seeing improvements in message processing. No messages are lost.
Posted Nov 29, 2024 - 04:36 EST
Identified
We are working on mitigation. No messages are lost.
Posted Nov 29, 2024 - 04:14 EST
Investigating
We are observing delayed delivery in the EU since 7.00 UTC. We are investigating the issue.
Posted Nov 29, 2024 - 03:36 EST
This incident affected: SMTP Delivery (Outbound Message Delivery) (SMTP Delivery - EUROPE) and Transmissions API (Transmissions API - EUROPE).