Elevated reporting error rates and data processing delays for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 09:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2019 - 09:27 EST
Update
We are continuing to investigate this issue.
Posted Dec 04, 2019 - 09:26 EST
Investigating
Our data processing services are running behind and we're seeing intermittent slowness and elevated error rates on our reporting APIs. Specifically, some customers may see latency issues, 500 errors or a delay of data on:

Web UI
Metrics API

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted Dec 04, 2019 - 09:17 EST
This incident affected: SparkPost Application (WebUI) (SparkPost Application - USA), Metrics API (Metrics API - USA), Message Events API (Message Events API - USA), and Event Webhook Delivery Service (Event Webhooks - USA).