Delay in event processing.

Incident Report for SparkPost

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 17:28 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2025 - 17:18 EST

Investigating

There is a delay in our events pipeline. This is causing metrics, events and webhooks to be delayed for a portion of data. Message sending is not effected.
Posted Dec 11, 2025 - 13:36 EST
This incident affected: Metrics API (Metrics API - USA), Events API (Events API - USA), SparkPost Application (WebUI) (SparkPost Application - USA), and Event Webhook Delivery Service (Event Webhooks - USA).