Data processing delays for SparkPost customers - US and EU regions

Incident Report for SparkPost

Resolved

The incident has been resolved.
Posted Dec 05, 2025 - 17:23 EST

Update

Metrics API is fully caught up. We are continuing work to restore full data availability in the UI.
Posted Dec 05, 2025 - 16:43 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 05, 2025 - 15:24 EST

Investigating

Our data processing services are running behind; some customers may see a delay of data available via the:

- SparkPost App (webUI): Signals Reports
- Events API
- Metrics API

Message injection and outbound message delivery are not impacted - all messages are flowing as expected.
Posted Dec 05, 2025 - 14:16 EST
This incident affected: Metrics API (Metrics API - USA, Metrics API - EUROPE) and SparkPost Application (WebUI) (SparkPost Application - USA, SparkPost Application - EUROPE).