Issue with updating payment information

Incident Report for SparkPost

Resolved

This incident has been resolved.
Posted May 12, 2026 - 09:38 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2026 - 09:10 EDT

Identified

We’re currently investigating an issue that prevented some customers from updating their payment details.

The root cause has been identified, and a fix is being implemented.
Posted May 12, 2026 - 08:48 EDT