We are seeing an increase in "delays"/4xx errors on outbound message delivery for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Postmortem

Summary: During this incident some customers hosted in the US region observed latency/slowness of outbound message delivery. For the impacted customers, a portion of messages were sent later than intended (up to 1.5 hours late). Delay events were not logged for the affected messages (contrary to the original report) because they were not attempted for delivery during the incident.

Incident Period: Jan 28 2019 from approximately 3:45 PM to 5:15 PM EST

Root Cause & Corrective Actions: The root cause was an availability issue of an underlying component used for suppression checks. We have identified several corrective actions: we made immediate improvements to the caching tier and over the next several weeks we’ll move to a more robust solution for storing suppression data.

Posted 7 months ago. Jan 31, 2019 - 12:23 EST

Resolved
This incident has been resolved.
Posted 7 months ago. Jan 28, 2019 - 17:01 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Jan 28, 2019 - 16:44 EST
Identified
We are seeing an increase in "delays"/4xx errors on outbound message delivery for some SparkPost and SparkPost Enterprise customers (US hosted only)
Posted 7 months ago. Jan 28, 2019 - 16:10 EST
This incident affected: Transmissions API (Transmissions API - USA) and SMTP Delivery (Outbound Message Delivery) (SMTP Delivery - USA).