Ongoing issues for messages destined to Office 365 domains
Incident Report for SparkPost
Resolved
We are working directly with those customers who are still impacted by this issue.
Posted Mar 07, 2024 - 12:54 EST
Update
A few customers are continuing to report delivery issues for messages destined to Office 365 addresses - junk foldering and elevated click rates.
If you are still experiencing messages landing in junk/quarantine at Office 365:
-- Reach out to Microsoft Office 365 Support
-- Contact our Support Team

We continue to work with Microsoft on this matter.
Posted Feb 29, 2024 - 17:01 EST
Update
Some customers are continuing to report delivery issues for messages destined to Office 365 addresses: junk foldering and elevated click rates. We continue to work with Microsoft on this matter - they have suggested that our customers reach out to Microsoft Office 365 Support if emails unexpectedly land in junk/quarantine. We will provide updates via this Incident.
Posted Feb 26, 2024 - 16:07 EST
Update
Some customers are continuing to report delivery issues for messages destined to Office 365 addresses: junk foldering and elevated click rates. We continue to work with Microsoft on this matter - they have suggested that our customers reach out to Microsoft Office 365 Support if emails unexpectedly land in junk/quarantine. We will provide updates via this Incident.
Posted Feb 23, 2024 - 17:52 EST
Update
Some customers are continuing to report delivery issues for messages destined to Office 365 addresses (junk foldering and elevated click rates). We continue to work with Microsoft on this matter. We will provide updates via this Incident when we receive updates from Microsoft.
Posted Feb 21, 2024 - 17:30 EST
Update
Some customers are continuing to report delivery issues for messages destined to Office 365 addresses. We continue to work with Microsoft on this matter. We will provide updates via this Incident when we receive updates from Microsoft.
Posted Feb 20, 2024 - 18:28 EST
Update
Some customers are continuing to report delivery issues for messages destined to Office 365 addresses. We continue to work with Microsoft on this matter. We will provide updates via this Incident when we receive updates from Microsoft.
Posted Feb 16, 2024 - 16:25 EST
Update
Some customers continue to report (1) messages are going to the junk/spam folder, and, (2) an elevated number of opens and clicks from Office 365 addresses. We are continuing to engage with Microsoft. We will provide updates via this Incident when we receive updates from Microsoft; the next update will be no later than 5 pm EST Friday.
Posted Feb 15, 2024 - 17:03 EST
Identified
Some customers continue to report (1) messages are going to the junk/spam folder, and, (2) an elevated number of opens and clicks from Office 365 addresses. We continue to engage with Microsoft and we have escalated this issue. We will provide updates via this Incident when we receive updates from Microsoft; the next update will be no later than 6 pm EST Thursday.
Posted Feb 15, 2024 - 11:37 EST
This incident affected: Mailbox Provider Service Interruption.