Elevated data processing delays for some SparkPost and SparkPost Enterprise customers (US hosted only)
Incident Report for SparkPost
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 24, 2019 - 13:40 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Jan 24, 2019 - 12:56 EST
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. Jan 24, 2019 - 12:29 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. Jan 24, 2019 - 12:28 EST
Investigating
Our data processing services are running behind and we're seeing intermittent slowness and elevated error rates on our reporting APIs. Specifically, some customers may see a delay of data on:

Web UI
Metrics API
Message Events API
Webhooks
Events Search API

Message injection and outbound message delivery is not impacted - all messages are flowing as expected.
Note: This issue does not impact our SparkPost customers hosted in the EU.
Posted 5 months ago. Jan 24, 2019 - 11:57 EST
This incident affected: SparkPost Application (WebUI) (SparkPost Application - USA), Metrics API (Metrics API - USA), Event Webhook Delivery Service (Event Webhooks - USA), Message Events API (Message Events API - USA), and Relay Webhooks Delivery Service (Relay Webhooks - USA).